using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)";
string substitution = @"";
string input = @"func1(func2(arg1, arg2),func3(func4(arg3)),arg4)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}