import re
regex = re.compile(r"(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)")
test_str = "func1(func2(arg1, arg2),func3(func4(arg3)),arg4)"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)