re = /(?:^[^\(\)]*?\()?(?:(.*?\)),|(.*?)\)$)/
str = 'func1(func2(arg1, arg2),func3(func4(arg3)),arg4)'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result