# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\\/a>)/$2/gm;t' <<< "this is a bet and he is <a id=\"sss\" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>
<a href=''> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy"