import re
regex = re.compile(r"(<a[^href]*href=[\"']{2}[^>]*>)([^<>]*|.*)(<\/a>)", flags=re.MULTILINE)
test_str = ("this is a bet and he is <a id=\"sss\" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a> \n"
"<a href=''> <i>Yammy </i> <br/> </a>\n\n"
"this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy")
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)