const regex = /(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\/a>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a[^href]*href=["\']{2}[^>]*>)([^<>]*|.*)(<\\\/a>)', 'gm')
const str = `this is a bet and he is <a id="sss" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>
<a href=''> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);