// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\/a>)"#).unwrap();
let string = "this is a bet and he is <a id=\"sss\" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>
<a href=''> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}