package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\/a>)`)
var str = `this is a bet and he is <a id="sss" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>
<a href=''> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}