using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a[^href]*href=[""']{2}[^>]*>)([^<>]*|.*)(<\/a>)";
string substitution = @"$2";
string input = @"this is a bet and he is <a id=""sss"" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a>
<a href=''> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}