$re = '/(<a[^href]*href=["\']{2}[^>]*>)([^<>]*|.*)(<\/a>)/m';
$str = 'this is a bet and he is <a id="sss" href=\'\' dfsd fdg >Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a href=\'\'>Yammy</a>
<a href=\'\'> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href=\'http://www.google.com\'>Google</a> and say he Yammy';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;