#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\/a>)"
Local $sString = "this is a bet and he is <a id="sss" href='' dfsd fdg >Mansoon</a> and he please search on <a href='http://www.google.com'>Google</a> and say he <a href=''>Yammy</a> " & @CRLF & _
"<a href=''> <i>Yammy </i> <br/> </a>" & @CRLF & _
"" & @CRLF & _
"this is a bet and he is Mansoon and he please search on <a href='http://www.google.com'>Google</a> and say he Yammy"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)