use strict;
my $str = 'this is a bet and he is <a id="sss" href=\'\' dfsd fdg >Mansoon</a> and he please search on <a href=\'http://www.google.com\'>Google</a> and say he <a href=\'\'>Yammy</a>
<a href=\'\'> <i>Yammy </i> <br/> </a>
this is a bet and he is Mansoon and he please search on <a href=\'http://www.google.com\'>Google</a> and say he Yammy';
my $regex = qr/(<a[^href]*href=["']{2}[^>]*>)([^<>]*|.*)(<\/a>)/mp;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";