# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/?(?:img)[^>]*>)|<[^>]+>//g;t' <<< "<dynamic style=\"font-size: 10pt; line-height: 1.6;\"><span style=\"background-color:#FF0000;\">>name<</span></dynamic>
<span style=\"background-color:#FF0000;\">>name<</span>
<span style=\"background-color:#FF0000;\">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src=\"sdfijsdofijsdofijsdoifjsdiof\"/>"