import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\/?(?:img)[^>]*>)|<[^>]+>";
final String string = "<dynamic style=\"font-size: 10pt; line-height: 1.6;\"><span style=\"background-color:#FF0000;\">>name<</span></dynamic>\n\n"
+ "<span style=\"background-color:#FF0000;\">>name<</span>\n"
+ "<span style=\"background-color:#FF0000;\">>name<</span>\n\n"
+ "<dynamic>>sender<</dynamic>\n\n"
+ "<dynamic>>email<</dynamic>\n"
+ "<img src=\"sdfijsdofijsdofijsdoifjsdiof\"/>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}