use strict;
my $str = '<dynamic style="font-size: 10pt; line-height: 1.6;"><span style="background-color:#FF0000;">>name<</span></dynamic>
<span style="background-color:#FF0000;">>name<</span>
<span style="background-color:#FF0000;">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src="sdfijsdofijsdofijsdoifjsdiof"/>';
my $regex = qr/(<\/?(?:img)[^>]*>)|<[^>]+>/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";