#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(<\/?(?:img)[^>]*>)|<[^>]+>"
Local $sString = "<dynamic style="font-size: 10pt; line-height: 1.6;"><span style="background-color:#FF0000;">>name<</span></dynamic>" & @CRLF & _
"" & @CRLF & _
"<span style="background-color:#FF0000;">>name<</span>" & @CRLF & _
"<span style="background-color:#FF0000;">>name<</span>" & @CRLF & _
"" & @CRLF & _
"<dynamic>>sender<</dynamic>" & @CRLF & _
"" & @CRLF & _
"<dynamic>>email<</dynamic>" & @CRLF & _
"<img src="sdfijsdofijsdofijsdoifjsdiof"/>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)