const regex = /(<\/?(?:img)[^>]*>)|<[^>]+>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/?(?:img)[^>]*>)|<[^>]+>', 'g')
const str = `<dynamic style="font-size: 10pt; line-height: 1.6;"><span style="background-color:#FF0000;">>name<</span></dynamic>
<span style="background-color:#FF0000;">>name<</span>
<span style="background-color:#FF0000;">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src="sdfijsdofijsdofijsdoifjsdiof"/>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);