import re
regex = re.compile(r"(<\/?(?:img)[^>]*>)|<[^>]+>")
test_str = ("<dynamic style=\"font-size: 10pt; line-height: 1.6;\"><span style=\"background-color:#FF0000;\">>name<</span></dynamic>\n\n"
"<span style=\"background-color:#FF0000;\">>name<</span>\n"
"<span style=\"background-color:#FF0000;\">>name<</span>\n\n"
"<dynamic>>sender<</dynamic>\n\n"
"<dynamic>>email<</dynamic>\n"
"<img src=\"sdfijsdofijsdofijsdoifjsdiof\"/>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)