// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<\/?(?:img)[^>]*>)|<[^>]+>").unwrap();
let string = "<dynamic style=\"font-size: 10pt; line-height: 1.6;\"><span style=\"background-color:#FF0000;\">>name<</span></dynamic>
<span style=\"background-color:#FF0000;\">>name<</span>
<span style=\"background-color:#FF0000;\">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src=\"sdfijsdofijsdofijsdoifjsdiof\"/>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}