package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<\/?(?:img)[^>]*>)|<[^>]+>`)
var str = `<dynamic style="font-size: 10pt; line-height: 1.6;"><span style="background-color:#FF0000;">>name<</span></dynamic>
<span style="background-color:#FF0000;">>name<</span>
<span style="background-color:#FF0000;">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src="sdfijsdofijsdofijsdoifjsdiof"/>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}