import Foundation
let pattern = #"(<\/?(?:img)[^>]*>)|<[^>]+>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<dynamic style="font-size: 10pt; line-height: 1.6;"><span style="background-color:#FF0000;">>name<</span></dynamic>
<span style="background-color:#FF0000;">>name<</span>
<span style="background-color:#FF0000;">>name<</span>
<dynamic>>sender<</dynamic>
<dynamic>>email<</dynamic>
<img src="sdfijsdofijsdofijsdoifjsdiof"/>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)