# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(test\b)(?=(?:[^"]|"[^"]*")*$)/HELLOWORLD/gm;t' <<< "Hello my name is \"test\" im a test
test is testing"