const regex = /(test\b)(?=(?:[^"]|"[^"]*")*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(test\\b)(?=(?:[^"]|"[^"]*")*$)', 'gm')
const str = `Hello my name is "test" im a test
test is testing`;
const subst = `HELLOWORLD`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);