re = /(test\b)(?=(?:[^"]|"[^"]*")*$)/m
str = 'Hello my name is "test" im a test
test is testing'
subst = 'HELLOWORLD'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result