import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(test\\b)(?=(?:[^\"]|\"[^\"]*\")*$)";
final String string = "Hello my name is \"test\" im a test\n"
+ "test is testing";
final String subst = "HELLOWORLD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}