import Foundation
let pattern = #"(test\b)(?=(?:[^"]|"[^"]*")*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello my name is "test" im a test
test is testing
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"HELLOWORLD"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)