use strict;
my $str = 'Hello my name is "test" im a test
test is testing';
my $regex = qr/(test\b)(?=(?:[^"]|"[^"]*")*$)/mp;
my $subst = 'HELLOWORLD';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";