$re = '/(test\b)(?=(?:[^"]|"[^"]*")*$)/m';
$str = 'Hello my name is "test" im a test
test is testing';
$subst = "HELLOWORLD";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;