import re
regex = re.compile(r"(test\b)(?=(?:[^\"]|\"[^\"]*\")*$)", flags=re.MULTILINE)
test_str = ("Hello my name is \"test\" im a test\n"
"test is testing")
subst = "HELLOWORLD"
result = regex.sub(subst, test_str)
if result:
print(result)