#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(test\b)(?=(?:[^"]|"[^"]*")*$)"
Local $sString = "Hello my name is "test" im a test" & @CRLF & _
"test is testing"
Local $sSubst = "HELLOWORLD"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)