using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(test\b)(?=(?:[^""]|""[^""]*"")*$)";
string substitution = @"HELLOWORLD";
string input = @"Hello my name is ""test"" im a test
test is testing";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}