using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*<(\d{1,3}(?:\.\d{1,3}){3})>.*";
string substitution = @"$1";
string input = @"%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}