// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*<(\d{1,3}(?:\.\d{1,3}){3})>.*").unwrap();
let string = "%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}