package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*<(\d{1,3}(?:\.\d{1,3}){3})>.*`)
var str = []byte(`%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}