import Foundation
let pattern = #".*<(\d{1,3}(?:\.\d{1,3}){3})>.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}