import re
regex = re.compile(r".*<(\d{1,3}(?:\.\d{1,3}){3})>.*")
test_str = "%BER-1-887373: Group <Connect> User <gacan> IP <72.34.184.200>"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)