using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(te)(?!\w*>)";
string substitution = @"<mark>$1</mark>";
string input = @"‘This is a test string’
<cite> — some <test.> wrapped too</cite>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}