use strict;
my $str = '‘This is a test string’
<cite> — some <test.> wrapped too</cite>';
my $regex = qr/(te)(?!\w*>)/p;
my $subst = '<mark>$1</mark>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";