const regex = /(te)(?!\w*>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(te)(?!\\w*>)', 'g')
const str = `‘This is a test string’
<cite> — some <test.> wrapped too</cite>`;
const subst = `<mark>$1</mark>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);