re = /(te)(?!\w*>)/
str = '‘This is a test string’
<cite> — some <test.> wrapped too</cite>'
subst = '<mark>$1</mark>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result