$re = '/(te)(?!\w*>)/';
$str = '‘This is a test string’
<cite> — some <test.> wrapped too</cite>';
$subst = "<mark>$1</mark>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;