import re
regex = re.compile(r"(te)(?!\w*>)")
test_str = ("‘This is a test string’\n"
"<cite> — some <test.> wrapped too</cite>")
subst = "<mark>$1</mark>"
result = regex.sub(subst, test_str)
if result:
print(result)