# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++/$not_whole_word/gm;t' <<< "test ajjjo new
here bbb cca
here abbbbbc x
test jjka"