// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++").unwrap();
let string = "test ajjjo new
here bbb cca
here abbbbbc x
test jjka";
let substitution = "$not_whole_word";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}