const regex = /\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?<whole_word>[a-z])\\k{whole_word}++\\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\\k{not_whole_word}++', 'gm')
const str = `test ajjjo new
here bbb cca
here abbbbbc x
test jjka`;
const subst = `$not_whole_word`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);