import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<whole_word>[a-z])\\k\\{whole_word\\}++\\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\\k\\{not_whole_word\\}++";
final String string = "test ajjjo new\n"
+ "here bbb cca\n"
+ "here abbbbbc x\n"
+ "test jjka";
final String subst = "$not_whole_word";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}