import re
regex = re.compile(r"\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++", flags=re.MULTILINE)
test_str = ("test ajjjo new\n"
"here bbb cca\n"
"here abbbbbc x\n"
"test jjka")
subst = "$not_whole_word"
result = regex.sub(subst, test_str)
if result:
print(result)