use strict;
my $str = 'test ajjjo new
here bbb cca
here abbbbbc x
test jjka';
my $regex = qr/\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++/mp;
my $subst = '$not_whole_word';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";