package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++`)
var str = `test ajjjo new
here bbb cca
here abbbbbc x
test jjka`
var substitution = "$not_whole_word"
fmt.Println(re.ReplaceAllString(str, substitution))
}