re = /\b(?<whole_word>[a-z])\k{whole_word}++\b(*SKIP)(*FAIL)|(?<not_whole_word>[a-z])\k{not_whole_word}++/m
str = 'test ajjjo new
here bbb cca
here abbbbbc x
test jjka'
subst = '$not_whole_word'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result